Results 1 to 9 of 9

Thread: Slow Wi-Fi speeds over my home LAN

  1. #1
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default Slow Wi-Fi speeds over my home LAN

    Ok, so I just bought a brand new laptop, finally. It has great specs and a nice Wi-Fi card, specifically the Intel WiFi 6 AX200

    My intrnet speeds are 100/10 Mbps. When accessing the internet and doing speed tests I max out those numbers for sure, but when I try to transfer a file on my home LAN over Wi-Fi on the 5GHz band to or from this laptop my speeds top out at around 15 MBps. Is this normal?

    I've hardwired this laptop and can achieve ~ 113-115 MBps transfers but I'm a little confused, I thought the Wi-fi card should do roughly the same.

    What am I missing here? Any thoughts?

    This is the first time I've had a "good" laptop so this just seems abnormal to me as I've always used hardwired connections, except for my Google Pixel 2 smartphone.
    Last edited by buffalofloyd; 2019-10-13 at 08:28 PM.
    Click here to access my Pink Floyd lists!

  2. #2
    Join Date
    Oct 2007
    Location
    Indiana, U.S.
    Posts
    1,986
    Thanks
    156
    Thanked 1,039 Times in 42 Posts

    Default

    Assuming that you're using an 802.11ac wireless adapter in your laptop and assuming that your router is also of that type, your speed appears to be limited according to which frequency bracket your laptop and router are communicating and what type of chipset is in your laptop's network adapter.
    If you're operating at 20MHz, your practical limit can be as low as 6.5Mbit/s, assuming the slower chipsets.
    If you're operating at 160MHz, your practical limit can be as high as 3466Mbit/s.
    "I don't know; I was really drunk at the time." - Henry McCullough

  3. #3
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default

    Quote Originally Posted by oldpink View Post
    Assuming that you're using an 802.11ac wireless adapter in your laptop and assuming that your router is also of that type, your speed appears to be limited according to which frequency bracket your laptop and router are communicating and what type of chipset is in your laptop's network adapter.
    If you're operating at 20MHz, your practical limit can be as low as 6.5Mbit/s, assuming the slower chipsets.
    If you're operating at 160MHz, your practical limit can be as high as 3466Mbit/s.
    Hey oldpink, thanks for the reply. I linked to the specific adapter I have above, which is technically the newest standard of WiFi 6 or 802.11ax I suppose. My router is a 802.11ac router, specifically this one Netgear Nighthawk Smart WiFi Router (R6700) - AC1750

    Annotation 2019-10-13 224511.jpg

    I would think both of these two devices communicating with each other should be more than sufficient to surpass 15MBps over WiFi on the 5GHz band within my LAN but this is not something I am very familiar with. Looking at the specs of the WiFi card it looks to me like it says it is 160MHz. I don't see any specific setting within my router that would prohibit my speeds.
    Click here to access my Pink Floyd lists!

  4. #4
    Join Date
    Jun 2006
    Posts
    2,130
    Thanks
    257
    Thanked 3,325 Times in 97 Posts

    Default

    I'd try disabling 2.4GHz on the router unless you really need it. Like everyone in an urban environment your airways are likely overcrowded. Cutting out that noise might make things easier on the router.

    It will also depend on the type of file (large or small) you're transferring between the 2 PCs. Are they within line-of-sight of each other or is it between walls or floors? At those high transfer rates, HDD speeds come into play, too. And check your firmware revisions for all devices involved. It's safe to say that Wifi6 is still in the experimental stage.

    Personally, I'm sticking with my wires for large file transfer for now.
    Last edited by tjmack; 2019-10-14 at 08:37 PM.

  5. #5
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default

    Quote Originally Posted by tjmack View Post
    I'd try disabling 2.4GHz on the router unless you really need it. Like everyone in an urban environment your airways are likely overcrowded. Cutting out that noise might make things easier on the router.

    It will also depend on the type of file (large or small) you're transferring between the 2 PCs. Are they within line-of-sight of each other or is it between walls or floors? At those high transfer rates, HDD speeds come into play, too. And check your firmware revisions for all devices involved. It's safe to say that Wifi6 is still in the experimental stage.

    Personally, I'm sticking with my wires for large file transfer for now.
    Sorry TJ, I totally missed your response to this, probably because you edited your original post. In any case I've tried from right by the router and downstairs in my room as well. I've tried both 2.4 and 5 and the speeds and I get around 13-14MBps on 5 and less on 2.4. I get the same speeds transferring to or from my NAS with NAS HDD's and between my laptop and PC with NVMe drives, doesn't seem to matter. Everything is up to date, all firmware and driver's on everything. The sizes of files don't seem to matter much either.
    Click here to access my Pink Floyd lists!

  6. #6
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default

    What kind of transfer speeds are you able to achieve on WiFi on your LAN while transferring files?
    Click here to access my Pink Floyd lists!

  7. #7
    Join Date
    Jul 2006
    Location
    Kentucky, USA
    Posts
    985
    Thanks
    1,581
    Thanked 558 Times in 32 Posts

    Default

    Try disabling LSO (Large Send Offload)

    You may or may not have this in your advanced settings but if you do give it a shot.

    1.Open Start Menu, right-click on Computer and select Properties
    2.Under Control Panel Home located on the left side of the window click on Device Manager
    3.You will get a list of all devices on your machine. Expand Network Adapters.
    4.Find your Network Card and double-click on it.
    5.Select Advanced tab. You will get a list filled with different options.
    6.Select Large Send Offload V2 (IPv4) and set the value to Disabled
    7.Do the same for Large Send Offload V2 (IPv6) if it is available
    8.Click OK

  8. #8
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default

    Quote Originally Posted by MarchingHammers View Post
    Try disabling LSO (Large Send Offload)

    You may or may not have this in your advanced settings but if you do give it a shot.

    1.Open Start Menu, right-click on Computer and select Properties
    2.Under Control Panel Home located on the left side of the window click on Device Manager
    3.You will get a list of all devices on your machine. Expand Network Adapters.
    4.Find your Network Card and double-click on it.
    5.Select Advanced tab. You will get a list filled with different options.
    6.Select Large Send Offload V2 (IPv4) and set the value to Disabled
    7.Do the same for Large Send Offload V2 (IPv6) if it is available
    8.Click OK
    Thank you for the response. I believe I came across this "fix" when I did some Google too. I think I tried it but it did not work. I will give it another shot and see how it goes and report back.

    Thanks again, and Merry Christmas to you and yours!
    Click here to access my Pink Floyd lists!

  9. #9
    Join Date
    Jul 2006
    Location
    Buffalo, The Queen City
    Posts
    3,273
    Thanks
    639
    Thanked 6,954 Times in 144 Posts

    Default

    Quote Originally Posted by MarchingHammers View Post
    Try disabling LSO (Large Send Offload)

    You may or may not have this in your advanced settings but if you do give it a shot.

    1.Open Start Menu, right-click on Computer and select Properties
    2.Under Control Panel Home located on the left side of the window click on Device Manager
    3.You will get a list of all devices on your machine. Expand Network Adapters.
    4.Find your Network Card and double-click on it.
    5.Select Advanced tab. You will get a list filled with different options.
    6.Select Large Send Offload V2 (IPv4) and set the value to Disabled
    7.Do the same for Large Send Offload V2 (IPv6) if it is available
    8.Click OK
    Yes, I remember now, my Wi-Fi card does not have either of those options available to me to disable.

    Annotation 2019-12-24 234552.png
    Click here to access my Pink Floyd lists!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •